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1.0 INTRODUCTION AND HISTORICAL BRIEF 
 
ARMD (Advanced Rotating Machinery Dynamics) is a new generation software 
package developed by RBTS to bring you the most advanced and complete 
rotor/bearing analysis capabilities for evaluating practically any bearing, rotor/bearing 
system, or mechanical drive train.  ARMD is developed for performing: 
 

 Rotor Dynamics 

 Torsional Vibration 

 Fluid-film Bearings 

 Rolling-element Bearings 

 Lubricant Temperature-dependent Properties 
 
ARMD is an integrated analysis package that incorporates state-of-the-art numerical 
and modeling features giving the ability to evaluate the physical system accurately and 
efficiently.  ARMD is user-friendly with options and features that include: 
 

 Context-sensitive help 

 Menu and windowing environment 

 Inter-module communication and data exchange 

 Graphical and text capabilities 

 Data range checking 

 Advanced file management system 
 
RBTS has developed and sold the engineering software “ARMD – Advanced Rotating 
Machinery Dynamics” worldwide since 1986.  Prior to 1986, RBTS principles were 
employed at The Franklin Institute Research Laboratory (FIRL) which was an 
internationally known scientific and engineering organization dating back to 1824.  Since 
1950, FIRL was a leader in the field of tribology and rotating machinery dynamics.  At 
FIRL, RBTS' principals were involved in the area of tribology and machinery dynamics.  
They have provided industry with engineering technical support and software for the 
design, development, fabrication, and application of fluid film/rolling element bearings 
and seals.  RBTS has been at the forefront in the development of advanced software for 
the evaluation of bearings, bearing systems, and vibration associated with rotating 
machinery and drive trains. 
 
RBTS, a Pennsylvania based engineering firm established in 1986, is entering 30th year 
of providing engineering services to industry for bearing design, rotor dynamics, and 
torsional vibration analysis.  RBTS supplies project engineering and field test services in 
those specialties across all industries, as well as to OEMs of turbo-machinery, 
compressors, gearboxes, bearings, and more.  RBTS’ team of engineers also provides 
technical training by means of an annual seminars at Penn State Great Valley and 
Cologne Germany, as well as customized, onsite training for customers.  Our website 
www.RBTS.com gives a good description of what we offer and the customers we serve. 

http://www.rbts.com/
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2.0 TECHNICAL SUPPORT AND SEMINARS 

2.1   Technical Support 

 
Technical support for ARMD can be received from either your local authorized 
distributor or through RBTS, Incorporated: 
 

RBTS, Inc. 
1041 West Bridge Street 
Phoenixville, PA  19460,  USA 
 
Tel:   610.415.0412 
Fax:  610.415.0413 
 
Web:  http://www.rbts.com 
e-mail: support@rbts.com 

 

2.2   Seminars 

 
RBTS offers seminars in the area of bearings and machinery dynamics annually.  The 
seminar, "FLUID-FILM/ROLLING-ELEMENT BEARING TECHNOLOGIES & 
ROTORDYNAMICS INTERACTION", is typically offered in the spring. 
 
An optional on-site tutorial and orientation session “Technology Transfer” is also 
available to RBTS customers.  The tutorial and orientation session covers software 
theory and application, bearings and rotor/bearing systems design, and interpretation of 
the results generated by ARMD software.  The session can be tailored to address client-
specific equipment and needs. 
 

2.3   Maintenance and Updates 

 
A one-year Software service agreement for support, maintenance, and updates of 
RBTS' software is provided free of charge for the first year with a software purchase. All 
modifications and improvements implemented during this year are automatically sent to 
users. The ARMD Annual Maintenance Agreement can be extended thereafter for a 
nominal fee each year. 
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3.0 ARMD OVERVIEW 
 
The ARMD software package is constructed from several modules (preprocessors, 
processors, and utilities) that interact with each other in a seamless fashion under one 
environment.  The top-level menu of ARMD (shown below) consists of the following 
preprocessors: 
 

 ROTLAT   Rotor dynamics lateral vibration. 
 
 TORSION   Torsional vibration. 
 

 VISCOS   Lubricant temperature dependent properties. 
 

 JURNBR   Fixed geometry fluid-film journal bearings. 
 

 HYBCBR   Fixed geometry fluid-film conical bearings. 
 

 THRSBR   Fixed & tilting-pad geometry fluid-film thrust bearings. 
 

 TILTBR   Tilting-pad geometry fluid-film journal bearings. 
 

 COBRA   Rolling element bearings.  
 

 ArmdWear  Wearing rings tool. 
 ArmdAeroCC Compressor wheels aerodynamic cross-coupling effects. 
 ArmdSqueeze Squeeze-film damper tool. 
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The overall hierarchy of the preprocessors and processors can be viewed as follows: 
 

 
 
 
The front end of ARMD communicates directly with all preprocessors.  Each of the 
preprocessors is utilized for input data creation, editing, saving, file management, 
processor communication, and text and graphical presentation of results. 
 
With any purchase option, all pre and post processing modules are supplied.  For 
example, if only the STABILITY solution module (ROSTAB) is ordered, the pre and post 
processor ROTLAT is supplied. 
 
The demonstration (Demo) version of ARMD includes ROTLAT, TORSION, VISCOS 
and JURNBR pre and post processors.  This Demo version is intended to give you a 
feel to the operation of ARMD and its various options.  The Demo includes sample 
problems of real life machinery and their support bearings for you to examine and 
familiarize yourself with the various input, output, and features of ARMD. 
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4.0 MANUAL ORGANIZATION AND 
TERMINOLOGY/NOTATION 

 
The ARMD user's manual is divided into nine (9) sections: 
 
1. ARMD   ARMD introduction, set-up, installation and operation (this section). 
 
2. ROTLAT  Rotor dynamics lateral vibration. 
 
3. TORSION  Torsional vibration. 
 
4. JURNBR  Cylindrical fluid-film fixed geometry journal bearings. 
 
5. HYBCBR  Conical fluid-film fixed geometry journal bearings. 
 
6. TILTBR   Fluid-film tilting-pad geometry journal bearings. 
 
7. THRSBR  Fluid-film fixed and tilting-pad geometry thrust bearings. 
 
8. COBRA  Rolling-element bearings. 
 
9. VISCOS  Lubricant temperature dependent properties. 
 
Each section has a detailed description of the module operation, system modeling, input data 
file construction, and processor output.  It also includes several practical sample problems. 
 
 
The following terms are used throughout the manual 
 
ARMDMENU   Front end program for ARMD. 
 
Filename.xxx  User specified file name with defaulted  
       extension set by the user interface (preprocessor). 
 
HYBCBR    Conical bearing analysis module. 
 
input file    ASCII file which is the source of data for  
       a processor (i.e. MOTOR-1.ROI is a ROTLAT input file). 
 
JURNBR    Journal bearing analysis module. 
module     Computer program. 
output file   File produced by a processor.  This includes 
       graphics and text files. (i.e. MOTOR-1.SYG and  
       MOTOR-1.SYO are graphics and text output files  
       respectively produced by ROSYNC processor). 
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postprocessor  Module used to perform post processing on an  
       output file.  The post processor eliminates the  
       need to run a full analysis (processor) again  
       when certain parameters are changed. 
 
preprocessor  Module used to control the contents of an input  
       file “user interface”.  This includes editing, printing and modeling. 
 
Processor 
or Solver    Program or module used to generate results. 
 
RORESP    Rotor dynamic time transient response analysis solver. 
 
ROSTAB    Rotor dynamic stability analysis solver. 
 
ROSTAT    Rotor dynamic static deflection analysis solver. 
 
ROSYNC    Rotor dynamic unbalance response analysis solver. 
 
ROTLAT    Rotor dynamic analysis module.  ROTLAT  
       controls ROSTAB, ROSTAT, ROTORMAP, ROSYNC and RORESP. 
 
ROTORMAP   Rotor dynamic analysis solver for generating  
       critical-speed and stability maps. 
 
THRSBR    Thrust bearing analysis module. 
 
TILTBR     Tilting-pad bearing analysis module. 
 
TORNAT    Torsional stability and natural frequency analysis solver.  
 
TORHRM    Torsional steady state response analysis solver. 
 
TORRSP    Torsional time transient response analysis solver. 
 
TORSION    Torsional analysis module.  TORSION 
       controls TORNAT, TORHRM and TORRSP. 
 
VISCOS    Lubricant viscosity analysis module. 
 
Preprocessor functions invoked from a menu will be represented in the form 
MainMenu>SubMenu>Function.  For example, View>Graph>by Template displays list of 
graph templates for current graphics data.  File>Print prints the contents of the current file to 
printer. 
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5.0 INSTALLATION 

5.1   Hardware and Software Requirements 

 
Hardware Requirements 
 
The ARMD software package requires the following hardware: 
 

- Personal computer with Pentium CPU or better 
- 600 MByte of disk space (approximately for full installation) 
- USB port dongle or software license supplied by RBTS, Inc. for purchased 
modules. 
- 512 Mbyte RAM minimum 
- VGA or SVGA graphics board with monitor (256 colors or better, 1024x768 

resolution or better) 
- For the 3 D Shaft Viewer, a modern GPU assisted graphics card supporting 

Microsoft DirectX 9.0c with on-board antialiasing.  
   NVidia: Geforce2 or higher required, Geforce 4(non-mx) or higher recommended. 
   ATI: Radeon 7500 or higher required, Radeon 9600 or higher recommended. 
   SiS, SiS, Intel and S3 cards might or might not be supported and dual mode 

graphics as found on some laptops may require Windows Control Panel 
configuration. In general, if after installing the latest driver for your graphics adaptor 
you cannot open the 3 D Shaft Viewer, the graphics adaptor may not be supported, 
please contact RBTS for further assistance. 

 
 
Software Requirements 
 

- Microsoft Windows Vista, Windows 7, Windows 8, Windows 10 or higher. 
- Windows XP is no longer supported. 
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5.2   CD Content 

 
ARMD is supplied on a CD-ROM (or downloaded from RBTS website) containing the 
following folders and files: 
 

 
 
Folder/File  Name Description 

 
Setup.exe file Installation program. Installs prerequisite software 

and all ARMD programs, utilities, configuration files 
and sample analyses. 
 

ARMD.ICO file CD Autoplay icon. 
. 

Autorun.inf file CD Autoplay configuration. 
 

Licensing folder Licensing utilities and documentation. 
 

Install folder Contains ARMD installation kits for pre-requisite 
software and all ARMD programs, utilities, 
configuration files and sample analyses. 
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5.3   Installation 

 
To install ARMD, insert the ARMD CD-ROM into the drive.  If the computer system does 
not automatically detect and start the installation, from the Start menu, choose the menu 
item Run… and click the Browse button to locate Setup.EXE in the root directory of the 
supplied CD.  Click OK to run the installation.  For downloaded copies of ARMD, open 
the “armdXX.exe” file. 
 
The install program prompts the user for required information.  The installation may be 
aborted at any time by clicking the Cancel button. 
 
*****  Installation Privileges  ***** 
 
Note 1: Windows operating systems, such as Vista, Windows 7, 8 and 10, will need to 

have “administrative” privileges in order to properly install/uninstall ARMD.  
Also, if ARMD is being installed for group access, the administrator for the 
group should be performing the installation. 

 
 
 
 
The following screen begins the installation.  Press the Start button to start the 
installation. 
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The initial step of the installation is to check the computer system for prerequisites for 
ARMD installation such as Microsoft.Net, Safenet drives, etc. as shown in the above 
screen.  When the Start button is pressed, missing prerequisites will be installed as 
shown in the screens below. 
 
 

 
 
 

 
 
 
Depending on your security settings, you may see the Microsoft Visual C++ 2008 
Components installation wizard as shown above.  After clicking “Next”, you will need to 
accept the Microsoft license terms and click “Install” to continue. 
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When Visual C++ installation competes, press the Finish button to continue 
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After all prerequisites have been confirmed to be installed, the ARMD software begins 
with the following screen. 
 
 

 
 
 
Press Next to start the ARMD software installation which will present the following 
screen. 
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For ARMD software installation to default folders, click the Typical button shown above 
and then press the Install button as shown below.  The Custom button in the above 
form allows the user to customize the installation folder where ARMD will be installed. 
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During the installation process, installation status with progress bars will be displayed as 
shown below. 
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When ARMD software installation completes, the following screen will be presented.   
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Press the Finish button to continue, which will display the final screen as shown below. 
 
 

 
 
 
Press the Done button to exit the install program. 
 
 
Note: ARMD installation, by default, will install the user interface programs, solvers, 

help files, manuals, DLL’s and system files in the Program Files folder (protected 
area on Vista, Windows 7, 8 and higher operating systems) under the folder 
name “RBTS”.  All other files including Templates, Samples, Lubricant & Material 
Properties, User files, etc. will be installed in the shared documents folders under 
the folder name “ARMDxx” (where xx is generally the version number of the 
ARMD software package). 

 
Default installation folders: 

 
C:\Program Files (x86)\RBTS, Inc\ARMD 
For user interface programs, solvers, help files, manuals, DLL’s and system files. 
 
C:\Users\Public\Documents\ARMDxx 
For all other files including Templates, Samples, Lubricant & Material Properties, 
User files, etc. 
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5.4   System Set-Up And Configuration – License Key (Dongle) 

 
 
ARMD solvers require an active license for operation.  Licensing is accomplished by 
either a physical USB hardware license key also known as “dongle” or a software 
license key.   
 
For purchased packages with hardware license key, just plug the key into an available 
USB port on your computer, no further installation is required since the key is 
preconfigured for operation prior to shipment. 
 
For purchased packages with software license key, there are two different types.  The 
first is a network concurrent access license key (for single or multiple users on a 
network), while the other is a standalone software license key.  For either option of the 
software license key, please read the “Software License Key Installation Instructions” 
supplied separately in a printed form or available in a PDF file 
“SoftwareLicenseKeyInstallation.pdf” in the downloaded or physically supplied ARMD 
CD.  An easy-to-use link is provided to this file during ARMD installation, located in the 
ARMD folder in the Windows Start > All Programs menu. 
 
 

5.5   Read-me.txt and Relnote5.txt 

 
For additional information on ARMD, check the read me (READ-ME.TXT) and release 
notes (RELNOTE.TXT) files, which will be installed in the main ARMD directory/folder if 
supplied.  Information may be also found on RBTS’ website at www.rbts.com 
 
 

5.6   Uninstall 

 
The ARMD software can be automatically uninstalled.   
 
To uninstall ARMD, from the Start Menu, select the Control Panel menu item.  Double 
click the icon labeled Add/Remove Programs or Programs and Features (depending 
on your operating system), highlight the item ARMD and press the Add/Remove button 
or select Uninstall/Change. 
 
*****  Privileges  ***** 
Remember, “administrative” privileges are required to uninstall ARMD software. 
.
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6.0 OPERATION 

6.1   General Operation 

 
When the ARMD package is installed, the installation, by default, will install the user 
interface programs, solvers, help files, manuals, DLL’s and system files in the Program 
Files folder under the folder name “RBTS, Inc”.  All other files including Templates, 
Samples, Lubricant & Material Properties, User files, etc. will be installed in the shared 
or public (depending on your operating system) documents folders under the folder 
name “ARMDxx” (where xx is the version number). 
 
As an example, for Windows 7 operating system, user interface programs, solvers, help 
files, manuals, DLL’s and system files will be installed in the default folder “C:\Program 
Files (x86)\RBTS, Inc\ARMD”, while all other files will be installed in the shared 
documents folder “C:\Users\Public\Documents\ARMDxx”. 
 
After installation/setup as described in Section 5, you can run the ARMD software from 
the Windows Start menu.  The first screen of ARMD will be displayed as shown below. 
 

 
 
At this point, you are at the top level/menu of the software package.  From this main 
menu, you can activate any of the preprocessor modules for bearings, bearing systems, 
rotor dynamics, torsional vibration, or lubricant properties calculation. 
 
Once a preprocessor module has been selected, from the main ARMD menu, the 
program will activate the selected preprocessor.  Details for each of the preprocessors 
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and their operation are described in the corresponding section of this manual or can be 
accessed from the preprocessor help menu. 
 
The ARMD package is fully user-friendly with context-sensitive help.  Function keys 
commonly used include the following (multiple key combinations are in the form 
[key1+key2]): 
 
 [Tab]        Moving to next field. 
 
 [Shift+Tab]     Moving to previous field. 
 
 [Home], [End], 
 [Page Up],  
 [Page Down], and 
 Arrow Keys     For moving around the screen and  
          data fields. 
 
 [F1]        On-line help. 
 
 [F2]        Display list of choices for field  
          (if available). 
 
 [F7]        Execute post processing programs in the  
          bearing routines. 
  
 OK button      Save edits and close form. 
 
 [Esc]/Cancel button  Cancel/abort. 
 
 
ARMD’s built in capabilities permits the usage of the right mouse button that 
incorporates all function key operations and more.  This capability eliminate the need of 
using the above function keys and give the user built-in edit capabilities by simply 
pressing a button. 
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Briefly, a typical session with ARMD may be as follows; 
 
1- Select a module from ARMD main menu “front end” (for example, TORSION). 
 
2- Place a problem in memory.  To use an existing file, use the File>Open command 

and select an existing one.  To create a new file, use the File>New command. 
 
3- Edit the contents of the input file.  If you need help at any time, press the F1 key 

(Help button) to display context-sensitive help or go to the help menu. 
 
4- Save the file under a filename.  Variations of an input file can be stored using the 

File>Save As command. 
 
5- If you want to examine the input file, you can look at it on the screen with the 

View>Input File command or print it using the File>Print command. 
 
6- Once the input file is setup with parameters and saved, execute the appropriate 

processor/solver from the Run menu. 
 
7- After the processor executes, examine the text and graphic output files generated 

by the processor using the Text Output and Graphics output utilities from the View 
menu. 

 
8- When you are finished with this preprocessor, run the command File>Exit to return 

to the top-level of ARMD menu. 
 
9- From the ARMD main menu “front end”, close the window to quit ARMD. 
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6.2   Projects 

 
A project allows related files to be grouped together in a subdirectory.  If a project is not 
open, ARMD software will handle files as it did in older versions (e.g. V4.1G0 or higher).  
Project functions are available from the Project menu and include: 
 
Project>New - prompts for a unique project name (up to eight characters).  An 

ARMD project file (.APF) is then created.  The new project is 
opened/activated. 

 
Project>Open - prompts for an .APF and opens/activates the project it represents. 
 
Project>Close- closes the current project. ARMD is now out of project mode. 
 
Project>Rename- rename an existing project to a new, unique name. 
 
Project>Copy - copy the files in a project to a new project. The .APF file is also 

copied to the new project name (eg. OLD.APF to NEW.APF) 
 
Project>Delete Project - deletes a project and all of the files in the project subdirectory.  

The .APF file is deleted and the subdirectory is removed. 
 
 *** WARNING *** All files in a project subdirectory will be 

copied/deleted regardless of whether ARMD or other software (eg. 
word processor) created them! 

 
Project>Add File - copy an existing file to the current project subdirectory.  The file 

does not have to be in a project subdirectory.  This is useful for 
moving older input files (Version 4.x or higher) into projects. 

  
Project>Delete File - delete an individual file.  The file does not have to be in a project 

subdirectory. 
 
Project>File Report - prompts for an .APF file and then displays a summary report of 
all files in the project subdirectory. 
 
Project>Project Report - displays a summary report of all projects available.  Project 
files (*.APF) are found in the main ARMD directory (eg. C:\Program Files\ARMDW). 
 
 
When ARMD is in project mode, the status line will show the current project name in the 
third slot from the right. Also, the "About" box in the preprocessors and utilities can be 
viewed to see what project is currently open. 
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6.3   Typical Session 

 
The following procedure describes a typical session using ARMD. 
 
 
A. Select the desired module from the main 

menu.  
 
For example, Torsional Vibration for performing 
drive train torsional vibration analyses. 
 
 
 
 
 
 
 

 

 

 
B. Place an input file in memory. 
 
To use an existing file, use the File>Open 
command and select an existing one.  To 
create a new file, use the File>New 
command.  With a new file, the program will 
prompt for the system of units (SI/Metric or 
US/English) to be used. 
 
 
 
 

 
C. Edit content of input file. 
 
System model data can be edited from the 
module main menu under SYSTEM, Options, 
Applied Torques, etc.  If you need help at any 
time, press the Help button or F1 key to display 
context-sensitive help. 
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OPTIONS in the main menu allows the user to 
define various output control parameters such 
as number of modes to be generated, steady-
state and time-transient response controls, 
continuation run information, etc. 
 

 
 

 
 

 
 

 

 
 

 
D. View graphical model to verify 

geometry. 
 
For graphical representation of system model, 
you can view the model on the screen with 
the View>System Model command or 
pressing the model icon on the tool bar.  The 
graphical model can also copied to other 
applications or printed. 
 
 
 

 
 
 
 
E. View saved input file. 
 
To view the input data file (flat ASCII file), 
which contains all the drive train geometry and 
operating conditions, use the View>Input file 
command.  The data in the input file can also 
be copied or printed. 
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F. Execute the appropriate processor from 

the Run menu. 
 
The RUN option will execute the selected 
solution module.  For example, if the torsional 
critical speed map for the constructed drive 
train Campbell diagram is to be generated, 
then, the Run>Natural Frequency option is 
activated and the solver executes, creating the 
results in both text and graphics format. 
 

 

 

 

 
 

 
G. View results in text format. 
 
The VIEW option of the main menu is 
used to examine the analysis results in 
either text or graphics form.  When 
View>Text Output is selected, text viewer 
utility is launched and the text output file is 
automatically loaded for viewing.   The 
viewing utility allows the user to scroll 
through the entire text output and file 
contents can be copied to other 
applications or sent to the printer. 
 

 
H. View results in graphics format. 
 
When View>Graphics Output is selected, the 
ARMDGraph utility is launched for graphics file 
loading and viewing.  Graphics and text output 
files generated with various processors have 
different file name extensions (i.e. .TNG, .TNO, 
etc.).  For extension name definitions please 
view the processors help windows.  These help 
windows are accessed from each of the 
modules HELP option in the main menu 
 

 
 

 
 
 

 
Pre-configured graphics file settings for the purposes of illustration have been provided.  To 
access these settings, for ARMDGRAPH utility (shown below) check the “Use Current Files” 
box and then press the “Open Workspace” to select the preconfigured settings of the Campbell 
diagram, then press “Show/Update Graphs” button to display the map (shown below). 
 
Users are encouraged to exercise the various options of  ARMDGRAPH utilities by selecting 
adding charts (1 to 4) and activating its various settings, scales, legend, heading, etc. 
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I. View mode shapes in 3D. 
 
A three dimensional (3D) view of the 
model with superimposed mode shapes 
can also be viewed in the 3 D Shaft 
Viewer selected from the View menu as 
shown below. 

 
 

 
 
 
 
 
 
 
J. Exit module return to ARMD front end. 
 

 
K. Close window of front end to exit 

ARMD. 
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6.4   Online Tutorial and Sample Session 

 
The ARMD modules such as ROTLAT, TORSION, JURNBR, etc. are supplied with on line help.  
When the package is installed for the first time, the tutorial session for the modules is turned on 
by default.  Thus, when a module is selected from ARMD main menu, the tutorial session is 
activated automatically.  Once the module is closed, the user is prompted to automatically 
activate the tutorial session, or not, when the module is selected again. 
 
As an example, if the TORSION module for drive train torsional vibration analysis is selected 
from the ARMD main menu, the module is activated and the tutorial session is launched 
automatically as shown below. 
 
 

 
 
 
The tutorial session is designed to quickly familiarize the user with the basic steps for the 
operation of the selected module. Clicking the mouse key in various areas of the session flow 
chart will give more information for the selected area. 
 
The ARMD modules tutorial sessions can also be activated from the selected module Help 
menu.  Additionally, Contents from the help menu (shown below for TORSION module), 
presents detailed information about the module and also includes a detailed step by step 
sample session for the creation of models, analysis and viewing the results. 
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6.5   Selected Screens 

 
Supplied with the ARMD software package are various sample rotor dynamics, torsional 
vibration, bearings, and lubricants input and output files.  For purposes of exercising ARMD and 
for viewing the various data forms and graphic plots presented on the following pages, each of 
the screens shown has the required steps/commands for viewing as illustrated below. 
 
 
 
 
DATA FORMS 
 

 
 

File>Open>Samples>SYNC-MOT.TOI 
 
Description: From the File menu, select the item labeled Open then select the input file SYNC-

MOT.TOI from the samples folder. 
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File>Open>Samples>SYNC-MOT.TOI 
System>Elements tab 

 
Description: From the File menu, select Open, then select the SYNC-MOT.TOI from 

the Samples folder.  From the System menu, select Elements to display 
the element information data form.  Color by material, using the color icon 

 from the tools sidebar.  Highlight rows 8 through 11 and press the 

summary icon  from the tools sidebar. 
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File>Open>Samples>SYNC-MOT.TOI 
View>System>Model 
Check boxes for: Display Stations Number 
 Display Scaled Discs 
Select: Mode Shape 

 
Description: From the File menu, select Open then select the SYNC-MOT.TOI from the 

Samples folder.  From the View menu, select System Model to graphically view 
the model or press the System Model icon.  Use left pane check boxes to 
show/hide various options (station numbers, mode shapes, etc.). 
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GRAPHICS PLOTS 
 
Graphic plots are displayed with the ARMD graphics utility ARMDGRAPH which is activated 
automatically from the view menus of any of the ARMD modules (TORSION, ROTLAT, 
JURNBR, etc.). 
 
When the Graphics Output item of the View menu is selected, various analyses results 
(previously performed for the currently loaded input file) are accessed from a list box.  Once an 
item is selected from the list box, the graphics utility is launched and the graphics file is loaded 
to memory for displaying the results graphically with the use of existing templates or user 
specified options. 
 

 
 

File>Open>Samples>SYNC-MOT.TOI 
View>Graphics Output>Time Transient Response 
 
Check the “Use Current Files” box and then press the “Open Workspace” 
to select the preconfigured settings of the four startup plots shown above, 
then press “Show/Update Graphs” button for display. 
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6.5.1   Rotor Dynamics (ROTLAT) Module 

 

File>Open>Samples>TurbineModelxxx.ROI

Steam Turbine 

Rotor Dynamics 

Evaluation

System Form > Discs tab

System form > Elements tab

System Form > Bearings tab

Stability 

Analysis
(ROSTAB)

Unbalance 

Response
(ROSYNC)

Time 

Transient  

Response
(RORESP)

Critical Speed 

& Stability 

Maps

ROTOR

DYNAMICS
(ROTLAT)

Selected elements summary

Edit 
Properties

System Model with influence of Bearings, Supports Flexibilities & Seals
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Natural Frequency, Mode Shapes & Stability 

Solvers Options

2D Graphics - Lowest Eight (8) Natural Frequencies Mode of Vibration

Critical Speed Map

Mode 1

Mode 2
Mode 3

Mode 4

First Bending Mode – Pinned-Pinned Supports
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Synchronous 
Unbalance 
Response

Motor Rotor Model – Un Shaded

Peak-to-Peak 

Amplitude of 

Vibration as a 

function of 

Speed

Amplification Factors at Select Stations

3D Graphics – Dynamically Deflected Rotor at Critical Speed of 2945 rpm
Animation available for enhanced viewing.



ARMD – Main 

 6-19 

 

Non-Synchronous 
Time Transient 
Response

Requested Stations and Directions for Output

9500 HP Motor Driving Reciprocating Compressor

Motor – 1 Bearing Support Compressor

Compressor Excitation 
Forces At Normal 

Operating Conditions

Shaft Vibratory Displacements at MAX Load MAX Speed

FFT - Motor Vibration at Support Bearing

Motor Shaft ORBIT at 
Support Bearing

Dynamically Transmitted Forces to Motor Bearing
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6.5.2   Journal Bearings Modules 

 

 
  

DIAGONAL & CROSS-

COUPLED STIFFNESS

KXX

KXY

KYX

KYY

Locus

Journal

Equilibrium

Supply Temp.

Lubricant Temperatures As A Function of Speed

 Load capacity / journal position

 Attitude angle
 Viscous power loss

 Righting moments

 Flow requirements

 Stability (bearing whirl/whip)

 Stiffness and damping (dynamic) coefficients
 Clearance and pressure distribution

 Recess pressures and flows

 Heat balance and temperature rises

Clearance PressureModel

Simulation capabilities with JURNBR include such effects as misalignment, pressurized boundaries or 

grooves, cavitation, structural deformation/surface deviation, lubricant feed circuitry with specified pressures 
or restrictors (capillary, orifice, or flow control valve), groove geometry and chamfers to mention a few.  

Performance results include the following. 

TAPERED-POCKET BEARING
3 Pad Configuration
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Pre-Configured Bearing Types. The newly developed package incorporates a significant number of 

preconfigured bearing types (templates) used in industry.  When creating a new bearing model the built-in 
wizard and templates expedite the creation of bearing models and provide bearing performance results in 

few keystrokes. Users can create additional templates of their specific bearing configurations and utilize 

them during their normal work flow. 

To assist the user 

when a pad profile 
has been selected, 

various fields/cells 

in the form will 
appear and be 

accessible or 
grayed out as 

shown below for 

the tapered land 
profile.  When a 

“User Defined” pad 
profile is selected, 

the user has 

complete freedom 
in configuring pad 

attributes. 

Bearing Pad Configuration. A vastly improved pad configuration tab allows the user to select from many 

standard bearing types, including special options, while restricting input to only those fields/cells pertinent to 
that type.  
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To enhance the 

prediction of bearing 
performance, a 

newly-developed 

groove feeding 
system with chamfer 

flow options provide 
an accurate model of 

bearing heat balance 

as a whole and on a 
pad per pad basis.

Complete Bearing 

Performance Results 

including bearing system 

heat balance and supply 

pressure considerations.

Heat balance calculation 

& temperature rise on a 

pad per pad basis for 

Flooded Environment.

Heat balance calculation 

& temperature rise on a 

pad per pad basis for 

Non-Flooded 

Environment / direct 

lubricant feed system.

S
c
ro

lla
b

le
 w

in
d

o
w

Run

Analysis

Pressure/ 

Clearance

Distributions

3D View Button
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Y

CONEA

T-Length

A-Length

BDIA1

BDIA2

BDIA

Ri

Ro
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Z

PADANG

 70

10

ORTANG

JOURNAL

PAD #4
PAD #3

PAD #2

PAD #1

Y

W

X

N

Step

o

o

4-Step-Pad Conical Geometry Journal Bearing For Tool Spindle Application Operation @ 3,600 Rpm.4-Step-Pad Conical Geometry Journal Bearing For Tool Spindle Application Operation @ 3,600 Rpm.

o

NSC STPNFC STP

GR VANG

PADAN G

R

OR TAN G

R

FLM AN G

i

PAD #2 PAD #1

14 Pad Tapered

Pocket Thrust Bearing 

After Optimized Design 

For Load, Temperature

And Stiffness.

3 Pad Tilting Pad

5”x2.5” Journal Bearing.

Load Between pads

Unloaded Upper Pad

Speed=1800 Rpm

Load=3500 lbs.

Recess

Recesses

Recess

Sample problem Number 4 (hydrostatic), Coal Pulverizer, Feed-End Trunnion Bearing, Flow Control Valve, Speed=12 RPM, Pad Angle=120 Deg.

 Y

CONEA

T-Length

A-Length

BDIA1

BDIA2
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Z
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ORTANG

JOURNAL

PAD #4
PAD #3
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Y
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X

N
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o
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4-Step-Pad Conical Geometry Journal Bearing For Tool Spindle Application Operation @ 3,600 Rpm.
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Pad

# 2

Pad

#  3

L
o

a
d

 A
n

g
le

fr
o

m
 +

X
 a

x
is

Pad

Offset

Groove

Angle Radial
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Setup

Clearance

3 Pad Tilting Pad 5” x 2.5” Journal Bearing

Load Between Pads Operating @ 1,800 Rpm.

Unloaded Upper Pad
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6.5.3   Lubricant Analysis (VISCOS) Module 

 

When VISCOS is launched for the first time, Tutorial is activated by 

default.  Tutorial can be accessed any time from the Help menu.

File>Open>Samples>VISCOS-1.VSI

The lubricant temperature dependent properties calculation module VISCOS supplied with the ARMD demo is fully operational version.

VISCOS has built –in lubricant data-base that can be accessed to retrieve lubricant properties.  The data-base is user-friendly with 

capabilities for users to add, delete and change records as they wish.

Results can be viewed in Text or graphics.  Built-in templates are used for quick graphic viewing. Users can create their own templates.

File>Open>Samples>VISCOS-1.VSI>Library

File>Open>Samples>VISCOS-1.VSI

View>Graphics Output
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6.5.4   Torsional Vibration (TORSION) Module 

 

Motor_gearbox-2-Stage Compressor Drive Train Torsional Response to  Synchronous Motor Start-up

File>Open>

Samples>

SYNC-MOT.TOI

Drive Train Torsional Modes of Vibration

Mode # 2

Mode # 1

File>Open>Samples>SYNC-MOT.TOI

System menu, Elements tab.

File>Open>Samples>SYNC-MOT.TOI  

View>Graphics Output>Natural Frequency>Mode Shapes

File>Open>Samples>SYNC-MOT.TOI  >  System Model

Help>Content>modeling Concepts
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File>Open>Samples>SYNC-MOT.TOI  >>  System Model  >> Checked Options from left pane with mode shape supper imposed on model.

File>Open>Samples>SYNC-MOT.TOI 

View>3 D Shaft Viewer for 3D presentation and mode shape animation.
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Graphics utilities 

permits user to define 

graph settings, scaling 

and many other 

options.

File>Open>Samples>SYNC-MOT.TOI  

View>Graphics Output>Natural Frequency>Campbell Diagram

Restore  graph settings from file: SYNC-MOT-CriticalSpeedMapPlot.usrx

Graphics screens can be copied to other 

applications such as word processors and 

other presentation utilities.
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File>Open>Samples>SYNC-MOT.TOI  

View>Graphics Output>Time Transient Response

Restore  graph settings from file: SYNC-MOT-TimeTransientResponse.usrx

Torsional natural frequencies can be dynamically excited by rotational 

speed or other excitation frequencies such as pulsating torques in 

synchronous motor during start-up.

TORSION predicts dynamic amplification and performs fatigue analysis 

for determining system acceptability for its intended application.

Drive Train passing 

through 1st torsional

natural frequency.

Motor 

Startup 

Speed

Motor 

Startup 

Average 

Torque

Low 

Speed 

Shaft 

Torque

High

Speed 

Shaft 

Torque



ARMD – Main 

 7-1 

7.0 UTILITIES 
 

7.1   Text Viewer 

 
Viewing text output files from the various ARMD software modules, by default is 
performed utilizing the NOTEPAD utilities supplied with Windows operating system.  
Users can configure their choice of text out files viewing utilities through the ARMD 
Settings accessed from the Help menu as shown below. 
 
 

 
 
 
The text viewing utility is activated from each of ARMD modules when the View>Text 
Output option is selected. 
 
The following list presents the text output file extensions generated with the various 
processors and their associated modules along with a brief description: 
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No. 

 
Module 

 
Menu Selection/Solver 

Text Output 
File 

Extension 

 
Description 

 
1 

 
ROTLAT 

 
Run>Static Deflection / 
ROSTAT 

 
.DFO 

 
Static deflection analysis results that 
includes slope, shear and moment 
diagrams, rotating system weight 
distribution and bearing loads.  

  Run>Stability Analysis / 
ROSTAB 

.STO Natural frequency, mode shape, 
stability and damping parameter 
analysis results. 

  Run>Unbalance Response 
/ ROSYNC 

.SYO Synchronous unbalance response 
vibratory amplitudes, phase angles, 
and dynamic forces and moments. 

  Run>Time Transient 
Response / RORESP 

.RSO Non-synchronous time transient 
response amplitudes, dynamic 
stresses, and dynamic forces. 

  Run>Critical Speed Map / 
ROTORMAP 

.CMO Natural frequencies as a function of 
bearing/support stiffness. 

  Run>Stability Map / 
ROTORMAP 

.SMO Natural frequencies, stability and 
damping parameters, and orbit 
direction as a function of rotational 
speed. 

 
2 

 
TORSION 

 
Run>Natural Frequency / 
TORNAT 

 
.TNO 

 
Torsional natural frequencies, mode 
shapes, damping parameters and 
torsional critical speed map (Campbell 
diagram). 

  Run>Steady State 
Response / TORHRM 

.TSO Torsional steady state response 
results including torques, stresses, 
angular displacement, velocity and 
acceleration. 

  Run>Time Transient 
Response / TORRSP 

.TRO Torsional response time history 
results including torques, stresses and 
fatigue life. 

 
3 

 
JURNBR 

 
Run>Bearing Analysis / 
JURNBR 

 
.OUT 

 
Fixed geometry journal bearing 
analysis results including loads, 
power-loss, flow requirements, film 
thicknesses, pressures, stiffness and 
damping coefficients, stability 
parameters, recess flows and 
pressures, etc. as a function of journal 
eccentricities. 

  Run>Post Processor /  
POSTMC (multiple case) 

.PSO Fixed geometry journal bearing 
analysis results similar to above as 
well as heat balance results as a 
function of user specified range of 
operating conditions. 

 
4 

 
HYBCBR 

 
Run>Bearing Analysis / 
HYBCBR 

 
.HCO 

 
Conical geometry journal bearing 
analysis results including loads, 
power-loss, flow requirements, film 
thicknesses, pressures, stiffness and 
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No. 

 
Module 

 
Menu Selection/Solver 

Text Output 
File 

Extension 

 
Description 

 
 

 
HYBCBR 

 
 

 
 

 
damping coefficients, stability 
parameters, recess flows and 
pressures, etc. as a function of journal 
eccentricities.. 

 
 

 
 

 
Run>Post Processor /  
HYBPSTMC (multiple case) 

 
.HPO 

 
Conical geometry journal bearing 
analysis results similar to above as 
well as heat balance results as a 
function of user specified range of 
operating conditions. 

 
5 

 
TILTBR 

 
Run>Single / SINGLE  

 
.SNO 

 
Tilting-pad geometry journal bearing 
analysis results of a single pad as a 
function of pivot film thickness. 

  Run>Assembly / 
ASSEMBLY 

.ASO Tilting-pad geometry journal bearing 
analysis results including load, power-
loss, flow requirements, film 
thicknesses, pressures, stiffness and 
damping coefficients, etc. as a 
function of journal eccentricities or 
applied loads.. 

  Run> Post Processor /  

TILPSTMC (multiple case) 

.TPO Tilting-pad geometry journal bearing 
analysis results similar to above as 
well as heat balance results as a 
function of user specified range of 
operating conditions. 

 
6 

 
THRSBR 

 
Run>Bearing Analysis / 
THRSBR 

 
.TOT 

 
Thrust bearing analysis results 
including load, power-loss, flow 
requirements, film thicknesses, 
pressures, stiffness and damping 
coefficients, etc. as a function of 
bearing axial clearance.. 

  Run>Post Processor /  
THRPSTMC (multiple case) 

.RPO Thrust bearing analysis results similar 
to above as well as lubricant heat 
balance results as a function of user 
specified range of operating 
conditions.. 

 
7 

 
BEARINGS 

 
Run>Post Processor /  
Single Case 

 
.TMO 

 
Text output from run of bearing solver 
within single case post processor for 
purpose of viewing 3-D graphical 
output. ( JURNBR = INTER.TMO 
HYBCBR = CINTER.TMO, 
THRSBR = THRPOST.TMO, 
TILTBR = TILPOST.TMO ). 

 
8 

 
VISCOS 

 
Run>Viscosity / VISCOS 

 
.VSO 

 
Lubricant temperature dependent 
properties.). 
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7.2   Graphics Viewer (ARMDGraph 2D) 

 

7.2.1   Introduction 

 
ARMDGraph is a newly developed general-purpose program that replaces its 
predecessor RBTSGRAF, with more user features and capabilities used to view two 
dimensional graphics output of ARMD processors (JURNBR, ROSYNC, TORNAT, etc.).  
ARMDGraph utility is supplied with each software package purchased from RBTS and it 
is installed during ARMD installation. 
 
ARMDGraph features include: 
 

 New workspace concept. 

 New graphical user interface to access and customize graphs. 

 New output file format (*.usrx) allows more customization of graphics data files 
than the previous .usr format. 

 Ability to create multiple graphs each of which may contain multiple charts. 

 Ability to plot lines in a chart from different graphics data files. 

 Backwards compatible with .usr files generated with RBTSGRAF graphing utility. 

 Customizable annotations and line markers. 

 Automatic detection of graphics data file changes/updates. 

 Clipboard support including: 
- Copy graph to clipboard as bitmap (.BMP) 
- Copy input file to clipboard as text file (.TXT) 

 Utilizes GUI help system.  

 Accelerator keys for accessing menu items.  

 Project menu for convenient access to project functions.  
 
ARMDGraph features include the following: 
 

 Multiple plots per window (1, 2, 3 or 4). 

  

1

2

3

4

1

2

3

1

21
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 Line, polar and FFT plots.  

 Templates for automatic configuration of graphs.  
 

 
 

 Save/restore user options (*.USRX), for custom graphs, including:  
- log, semilog or linear axis scaling. 
- automatic or manual axis scaling. 
- log, semilog or linear axis scaling.  
- automatic or manual axis scaling.  
- grid lines (ON or OFF). 
- legend position (hidden, inside or outside right).  
- draw curves with lines, symbols or both.  
- macro strings for flexible title assignment. 

 
 

7.2.2   Templates and User Options 

 
Templates are only available for graphics files with a fixed number of variables for 
output such as data files generated by processors like JURNBR, HYBCBR, TILTBR, 
THRSBR, and VISCOS modules which produce graphics output files independent of 
user specified parameters.  Processors for the ROTLAT and TORSION modules which 
produce variable amount of graphics output (depending on input file), do not have 
template entries.  Users may want to create option files for these graphics files as a type 
of "user-template". 
 
 

7.2.3   Graphics File Extensions 

 
The following list present the various graphics output file extensions generated with the 
various processors and their associated modules along with a brief description: 
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No. 

 
Module 

 
Menu Selection/Solver 

Graphics 
Output File 
Extension 

 
Description 

 
1 

 
ROTLAT 

 
Run>Static Deflection / 
ROSTAT 

 
.DFG 

 
Static deflection analysis results that 
includes slope, shear and moment 
diagrams, rotating system weight 
distribution and bearing loads.  

  Run>Stability Analysis / 
ROSTAB 

.STG Mode shapes with their natural 
frequency, stability and damping 
parameters. 

  Run>Unbalance Response / 
ROSYNC 

.SYG Synchronous unbalance response 
vibratory amplitudes, phase angles, 
and dynamic forces and moments. 

  Run>Unbalance Response / 
ROSYNC 

.SPG Synchronous unbalance response 
vibratory amplitudes at ±45 degrees 
from vertical Y-axis. 

  Run>Unbalance Response / 
ROSYNC 

.SBG Synchronous unbalance response 
orbits at bearing stations and for user 
selected initial, intermediate, and final 
operating speeds. 

  Run>Time Transient 
Response / RORESP 

.RSG Non-synchronous time transient 
response amplitudes. 

  Run>Critical Speed Map / 
ROTORMAP 

.CMG Natural frequencies as a function of 
bearing/support stiffness. 

  Run>Stability Map / 
ROTORMAP 

.SMG Natural frequencies, stability and 
damping parameters as a function of 
rotational speed. 

 
2 

 
TORSION 

 
Run>Natural Frequency / 
TORNAT 

 
.TNG 

 
Torsional mode shapes, their natural 
frequencies and damping parameters. 

  Run>Natural Frequency / 
TORNAT 

.TNC Torsional critical speed map 
(Campbell diagram). 

  Run>Steady State Response 
/ TORHRM 

.TEG Torsional steady state response 
containing element element 
torque/stress output results. 

  Run>Steady State Response 
/ TORHRM 

.TSG Torsional steady state response 
containing station vibration output 
results. 

  Run>Steady State Response 
/ TORHRM 

.TTG Torsional steady state response 
containing element thermal output 
results. 

  Run>Time Transient 
Response / TORRSP 

.TRG Torsional response time history 
results. 

 
3 

 
JURNBR 

 
Run>Bearing Analysis / 
JURNBR 

 
.GRF 

 
Fixed geometry journal bearing 
analysis results including loads, 
power-loss, flow requirements, film 
thicknesses, pressures, stiffness and 
damping coefficients, stability 
parameters, recess flows and 
pressures, etc. as a function of journal 
eccentricities. 
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No. 

 
Module 

 
Menu Selection/Solver 

Graphics 
Output File 
Extension 

 
Description 

 
 

 
JURNBR 

 
Run>Post Processor /  
POSTMC (multiple case) 

 
.PSG 

Fixed geometry journal bearing 
analysis results similar to above as 
well as heat balance results as a 
function of user specified range of 
operating conditions. 

 
4 

 
HYBCBR 

 

Run>Bearing Analysis / 
HYBCBR 

 
.HCG 

 
Conical geometry journal bearing 
analysis results including loads, 
power-loss, flow requirements, film 
thicknesses, pressures, stiffness and 
damping coefficients, stability 
parameters, recess flows and 
pressures, etc. as a function of journal 
eccentricities. 

 
 

 
 

Run>Post Processor /  
HYBPSTMC (multiple case) 

.HPG Conical geometry journal bearing 
analysis results similar to above as 
well as heat balance results as a 
function of user specified range of 
operating conditions. 

 
5 

 
TILTBR 

 
Run>Single / SINGLE  

 
.SNG 

 
Tilting-pad geometry journal bearing 
analysis results of a single pad as a 
function of pivot film thickness. 

  Run>Assembly / ASSEMBLY .ASG Tilting-pad geometry journal bearing 
analysis results including load, power-
loss, flow requirements, film 
thicknesses, pressures, stiffness and 
damping coefficients, etc. as a 
function of journal eccentricities or 
applied loads.. 

  Run> Post Processor /  

TILPSTMC (multiple case) 

.TPG Tilting-pad geometry journal bearing 
analysis results similar to above as 
well as heat balance results as a 
function of user specified range of 
operating conditions. 

 
6 

 
THRSBR 

 
Run>Bearing Analysis / 
THRSBR 

 
.THG 

 
Thrust bearing analysis results 
including load, power-loss, flow 
requirements, film thicknesses, 
pressures, stiffness and damping 
coefficients, etc. as a function of 
bearing axial clearance.. 

  Run>Post Processor /  
THRPSTMC (multiple case) 

.RPG Thrust bearing analysis results similar 
to above as well as lubricant heat 
balance results as a function of user 
specified range of operating 
conditions.. 

 
7 

 
VISCOS 

 
Run>Viscosity / VISCOS 

 
.VSG 

 
Lubricant temperature dependent 
properties.). 
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7.2.4   ARMDGraph Workspace 

 
ARMDGraph employs a Workspace concept to manage multiple graphs with 
associations to single or multiple graphics output files.  The workspace can be viewed to 
be a user settings form that contains user defined plot/chart configurations for graphics 
output files generated by ARMD solvers.   
 

 
 
The workspace consists of two basic left/right panels.  The left panel contains the 
graphs, charts, and graphic output files, while the right panel contains chart/graph 
settings.  A typical session/tutorial with is graphically shown below.  Further details and 
help are available after ARMD/ARMDGraph installation from within the help menu. 

  

1- Open graphics data file.

2- Files with templates.

Double click an entry.

2- Files with no templates.

3- Configure Workspace.

4- Press 

“Show/Update 

Graphs” 

button to 

display the 

chart/graph 

window.
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7.3   3-D Bearing Viewer 

 

7.3.1   Introduction 

 
BRGVU is a general purpose program used to view the 3-D graphical output of ARMD 
fluid-film bearing solvers (JURNBR, HYBCBR, THRSBR, TILTBR).  Output includes 
clearance, pressure and shear-stress distributions as well as structural deformation (if 
applicable). 
 
BRGVU is copied to your computer when the Utilities item and any fluid-film bearing 
package are selected from the Select Components dialog of the installation program. 
 

7.3.2   Main Menu 

 
The main menu of BRGVU is divided into the following menus: File, Edit, View, 
Contours, Deformation, Display, Zoom, Rotate, Colors, Window and Help. 
 
 
File Menu 
Open         opens a 3-D graphics file and loads its data into memory. 
           A window with a default view will then be displayed. 
 
Close         closes the currently open graphics file and  

          any view windows associated with it. 
 
Print          print the contents of the current view window. 
 
Print Preview       preview printer output for the current view window. 
 
Print Setup       configure the printer settings. 
 
Exit          exits BRGVU. 
 
 
Edit Menu 
Undo          undo last undoable command. 
 
Cut          cut selected object and paste to clipboard. 
 
Copy          copy selected object to clipboard (e.g. model view) 
 
Paste         paste clipboard contents to current context. 
 
 



ARMD – Main 

 7-10 

View Menu 
New          create and display new view window based 
           on currently active view. 
 
Save          save window settings to last restored .VUE file 
 
Save As        save window settings to a .VUE file 
  
Restore         restore window settings from a .VUE file 
 
 
Contours Menu 
None          checked if no contouring done. 
 
Clearance        checked if contouring by clearance. 
 
Pressure        checked if contouring by pressure.  
 
Shear-Stress       checked if contouring by shear-stress. 
 
Shading        checked if light shading is used. 
 
Automatic range     checked if program determines contour limits. 
 
User-specified range    checked if user specified contour limits are used. 
 
 
Deformation Menu 
None          checked if no deformation done. 
 
Clearance        checked if deformation by clearance. 
 
Pressure        checked if deformation by pressure.  
 
Shear-Stress       checked if deformation by shear-stress. 
 
Automatic scale factor   checked if program determines deformation scale factor. 
 
User-specified scale factor  checked if user-specified scale factor is used for  
           deformation. 
 
 
Display Menu 
Pads          display dialog for controlling which pads are displayed.  
           (Default=set 0) 
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Output Set        display dialog for selecting output set 
           for the current view window. 
 
Mesh         checked if mesh is drawn on model. 
           (Default=ON). 
 
Hidden Elements     checked if hidden elements are removed. 
           (Default=removed) 
 
Animate        checked if animation if ON (default=OFF). 
 
 
Zoom Menu 
Previous        restore previous zoom 
 
Enclose Model      display model to fit within view window. 
 
Zoom Out 1:1      restore default zoom level. 
 
Zoom In N:1       zoom out (factor of N). 
 
 
Rotate Menu 
Isometric        display isometric view. 
 
User specified…     display with user-specified rotation, translation, and zoom. 
 
XY Front        display model with 2-D perspective 
XY Back 
XZ Front 
XZ Back 
YZ Front 
YZ Back 
 
 
Colors Menu 
Contours        select colors for contouring 
 
Shading        select color for light shading. 
 
Mesh         select color for mesh grid. 
 
Text          select foreground color for text. 
 
Background       select background color for model and text. 
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Window Menu 
New          create new view window with default settings 
 
Cascade        cascade current view windows 
 
Tile Horizontally      tile current view windows horizontally 
 
Tile Vertically       tile current view windows vertically 
 
Arrange Icons      arrange icons for minimized view windows 
 
 
Help Menu 
Help Topics       displays table of contents for help file 
 
About         displays the program name, data, version 
           and copyright notice for BRGVU. 
 

7.3.3   View Settings 

 
View settings may be saved to and restored from disk via the View menu.  View setting 
files have the .VUE file extension. 
 

7.3.4   3-D File Extensions 

 
 

No. 
 

Module 
 

Processor/Solver 
File 

Extension 
 

Description 

 
1 

 
JURNBR 

 
JURNBR 

 
.JUV 

 
Clearance and pressure distributions 
and structural deformation. 

 
2 

 
HYBCBR 

 
HYBCBR 

 
.HYV 

 
Clearance and pressure distributions 
and structural deformation. 

 
3 

 
THRSBR 

 
THRSBR 

 
.THV 

 
Clearance and pressure distributions 
and structural deformation. 

 
4 

 
TILTBR 

 
SINGLE 

 
.TIV 

 
Clearance and pressure distributions. 
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7.4   3-D Shaft Viewer 

 

7.4.1   Introduction 

 
ARMD Shaft Viewer is an integrated graphics utility in the ARMD suite.  It uses modern 
3 D graphic rendering technology to provide a highly realistic view of model shaft 
systems which can be rotated, zoomed and moved to provide the user with a clear 
viewpoint of features of interest in the shaft system. Shaft systems designed in ROTLAT 
or TORSION can be loaded into the Shaft Viewer, which then automatically loads any 
model solution results of torsional natural frequency mode shapes, rotor stability mode 
shapes, and unbalanced response orbits. These model distortions/vibrations can be 
selected, scaled, and animated, showing a unique visual representation of the 
rotor/bearing system or mechanical drive train vibration characteristics from the ARMD 
Shaft Viewer WORKSPACE (shown below). 
 

 
 
The Shaft Viewer can be run as a stand-alone display utility either from the ARMD main 
menu or from the computer’s Start menu.  It is also fully integrated into the ROTLAT 
Rotor Dynamics and TORSION Torsional Vibration modules, where it can be accessed 
via the View menu as shown below (if run from ROTLAT or TORSION, it will start with 
the model in use fully loaded). 

Bearing

Disk
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ARMD Shaft Viewer is supplied with the Rotor Dynamics and Torsional Vibration 
modules purchased and it is automatically installed during ARMD installation. 
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7.4.2   Sample Session 

 
Rotor models can be opened directly from the Shaft Viewer main File menu.  Shaft 
models can be loaded into the Shaft Viewer from the File > Open or File > Recent Files 
main menu selections.  When using the File > Open menu selection, a Windows Open 
File dialog is displayed, starting either in the current ARMD project folder, or the most 
recently used folder if no ARMD project is open. 
 

 
 
Files displayed in the dialog are filtered by default to *.roi and *.toi files which contain 
ROTLAT and TORSION shaft system file specifications, respectively. 
 
After loading a shaft system model, the viewer will render it on the screen.  Shown 
below is the display of the sample COMPRES.ROI model, where annotation has been 
added in italics for this screen shot. 
 
By default, the display opens in the ISO view, with the axes rotated to show detail along 
all three axes. The viewpoint of the display can be modified by using the buttons on the 
left side of the display.  By pressing the + and – buttons, the display can be zoomed or 
rotated (shown below) about any of the three axes.  The arrow buttons in the middle of 
the Viewpoint group move the display left, right up and down. 
 
 



ARMD – Main 

 7-16 

 
 
Continuous motion can be achieved by holding any of the arrow buttons down.  The 
display can be reset at any time to one of 4 standard viewpoints, the default ISO view, 
or projections on the YZ, XZ, or XY planes.  If by any chance the viewpoint is modified 
to the point where the model is no longer visible, clicking on either a standard viewpoint 
or the Enclose button will re-center the model in the display.  The enclose button will re-
center the model without changing its orientation. 
 
The various elements of the model can be selected for display using the check boxes in 
the Visibility control group.  When the Solid and Mesh items are selected, the viewer 
performs an automatic level-of-detail (LOD) calculation considering the distance to the 
shaft system to determine when the mesh would be sufficiently dense to hide the solid 
display, and then suppresses the mesh display if needed. In the first screen shot above, 
the LOD has suppressed the mesh on the entire model.  Shown below are snapshots of 
how this display appears as we zoom in. 
 
 
 
 
 

Bearing

Disk
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Note that the LOD calculation is performed on an element by element basis, so that 
more distant elements will have their mesh suppressed while closer ones are shown. 
 

 
 
If the solid display is not selected but the mesh is, then the LOD calculation is not 
performed, and the mesh is shown for all elements. 
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Information about the shaft’s elements can be found in the shaft element display when 
an element is selected.  This display shows the size and length of each element. The 
element selected can be highlighted by selecting the mesh-only display.  As shown 
below, this highlights element 7 on the display by showing it in black. 
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The main feature of the Shaft Viewer is its ability to display and animate the motions 
calculated by the various ARMD solvers.  When the Shaft Viewer loads a ROTLAT or 
TORSION shaft system model, it looks for supported solver output files, and if they are 
present will load any or all of them automatically, no user interaction is needed.  These 
output sets are then presented to the user for display in the Output Set: drop-down box 
on the viewer’s main toolbar (shown below). 

 
 
Once an output set has been selected, the next step is to select a particular property in 
the set to be displayed.  For ROSTAB and TORNAT mode shapes, the property is the 
specific mode shape.  This is accomplished from the Output Set Property drop-down 
box (shown below). 

 
 

 
 
The scale of the distortions displayed can be adjusted using the Shape Amplitude text 
box (shown above) on the toolbar. 
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Displayed mode shapes and vibrational amplitudes (orbits) can be animated by 
pressing the play button.  During animation, clicking the Pause button will pause the 
animation at its current frame.  The Single Step button advances from the current to the 
next frame, while the Stop button resets the animation to frame 0.  Animation speed can 
be increased/decreased with the slider/speed bar shown above. 
 
In some cases, it can be easier to see the mode shapes or vibrational amplitudes 
without looking at the model’s solid or mesh displays.  Here’s a snapshot of the 
COMPRES.ROI sample problem first mode shape without the solid or mesh. 
 

 
 
The red line represents the location of the center of the shaft at each station in the 
model.  Animating this view can show better detail of the precise motions including 
relative phases at each station.  This is accomplished by using the Visibility check 
boxes positioned right above the animation controls (also shown below). 
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8.0 USER FEEDBACK REPORT 
 

Instructions Date:____/____/____ 

Use this form to report problems or recommend enhancements for RBTS products.  Please 
email, mail, or fax the form to: 
            RBTS, Inc. 
            1041 West Bridge Street 
            Phoenixville, PA 19460, USA 
            Tel:  (610) 415-0412   ;  Fax: (610) 415-0413 
            email: support@rbts.com 
 
 

User 

Name:___________________________________  Email:________________________ 
 
Company:________________________________  Telephone #:___________________ 
 
Address: _____________________________________________________ 
 
    _____________________________________________________ 
 
    _____________________________________________________ 
 
Check:   [ ] Software Problem    [ ] Software Enhancement 
     [ ] Documentation Problem  [ ] Documentation Enhancement 
     [ ] Other (please specify):__________________________________________ 
 
 

Software 

Name of Software:_______________________ Version of Software:__________________ 
 
Name of Operating System and Version:_________________________________________ 
 
 

Hardware 

Computer Manufacturer/Model Name____________________________________________ 
 
Is your computer connected to a network (yes/no)?_________________________________ 
 
Is your computer connected to a docking station (yes/no)?____________________________ 
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(OVER) 

Description 

Please describe the problem/enhancement below.  If it is a problem, please include information 
on reproducing the anomaly: 
 
___________________________________________________________________________ 
 
___________________________________________________________________________ 
 
___________________________________________________________________________ 
 
___________________________________________________________________________ 
 
___________________________________________________________________________ 
 
___________________________________________________________________________ 
 
___________________________________________________________________________ 
 
___________________________________________________________________________ 
 
___________________________________________________________________________ 
 
___________________________________________________________________________ 
 
___________________________________________________________________________ 
 
___________________________________________________________________________ 
 
___________________________________________________________________________ 
 
___________________________________________________________________________ 
 
___________________________________________________________________________ 
 
___________________________________________________________________________ 
 
___________________________________________________________________________ 
 
___________________________________________________________________________ 
 
___________________________________________________________________________ 
 
___________________________________________________________________________ 
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Purchasing Options 
ARMD is constructed  from various solution modules.  
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purchase, the package includes the software (CD or 

download), quick start manual, electronic user’s 

manual, technology transfer and training session 
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Personal computer with Microsoft Windows 7, 8, 10 or 
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Remember, with RBTS, you get more than 

just the programs, you get the company with more than 
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  Web:    www.rbts.com 
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ARMD is a well established software package used worldwide to 

perform complete rotating machinery dynamic analysis.  ARMD 

employs a user-friendly interface and window environment and 

context-sensitive help.  ARMD integrates the most advanced and 

complete rotor dynamics, torsional vibration, and bearing analysis 

programs under one environment in a seamless fashion to give you 

the power to model your rotating machinery with ease, efficiency, and 

above all accuracy.  Some applications in which ARMD has been 

utilized include rotating machinery such as a miniature air turbine for a 

dental drill, a large turbine generator set for a power plant, a small 

compressor for an air conditioner, a pump for an artificial heart, a fuel 

pump for a jet engine, an electric motor and spindle for a miniature 

computer hard disk, a canned pump for petrochemical processing 

plant, synchronous motor driven drive-trains, and a gear box for a 

uranium enrichment plant to name a few. 
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